Autor Thema: Mercedes NTG1 Navi Laufwerk  (Gelesen 14317 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

RockNRolla

  • Lv 4: Great Member
  • ***
  • Offline Offline
  • Beiträge: 201
    • Profil anzeigen
Mercedes NTG1 Navi Laufwerk
« am: 12. Dezember 2016, 10:42:49 »
Moinsen Takeshi und Co :D

Lang lang ists her. Musste sogar das Passwort zurücksetzen, weil ich einfach nicht mehr drauf gekommen bin :D  Achja und modcontrol gibts anscheinend auch nicht mehr.  Hat sich wohl viel geändert.

Naja. Man ist auch inzwischen Erwachsen geworden und statt PS2s hantiert man nun mit Navigationslaufwerken, weil man inzwischen einen Führerschein und ein Auto hat :D

Nun genug Nostalgie bevor jemand anfängt zu heulen :P
Ich habe folgendes Laufwerk "M2 5.6 DVD" von Mercedes, was nicht mehr Navigieren will, da es die Navi DVD nicht mehr liest. Früher hatte er lediglich sporadische Aussetzer aber mittlerweile ist funkstille.
Poti hab ich schon gedreht gehabt und das hat absolut nichts gebracht. Zettel mit Werten hab ich leider weggeschmissen.

Achja der Laser heisst SF-HD4. Gibt anscheinend mehrere Versionen. Flex gerade und flex gebogen. Die geraden sind, die die im Navi verbaut sind und leider auch dementsprechend teuer bzw vergriffen. Ich habe mir die gebogene Version geholt und etwas rumgepfuscht. Sehen kann man das Verfahren auf Youtube , wenn man nach SF-HD4 sucht. Gibt zwei Videos von einem Spanier(?) zu diesem Video. Kann auch verlinken, muss es eben mal rauskramen, falls es nicht so streng ist hier mit Videos und Links.

Ausserdem gibt es anscheinend noch eine Version mit weissem Laser cap. Ich glaube die hat nur einen Poti und kann nur CDs lesen. Ganz sicher bin ich mir aber nicht.

Nundenn. Der bestellte Laser ist nach 2 Wochen aus China eingetroffen. Die Statiklötpunkte waren auf der Flex. Hab diese entlötet und den Laser eingebaut. Aber nach wie vor will er nichts lesen.
Poti war auch ziemlich hoch gedreht. Auf 3.67k ohm. Hab den gestern bisschen runter auf 2k  gedreht. Rein aus Verzweiflung.

Ich habe paar kleine Batterien Reihengeschaltet und einfach mal an den Motor an der Schiene gehalten. Die Lasereinheit bewegt sich ganz normal. Vor und zurück. Mir ist auch die PS2 eingefallen als ich weiter auf der Platine gesucht habe und mir ein BA chip ins Auge gestochen ist.
Da is mir der gute alte Takeshi eingefallen :D

Werde später mal alle drei(?) ICs raussuchen und aufschreiben. Kann auch Bilder machen wenn nötig.

Danke für jede Hilfe :D



UPDATE:



So. Die ICs mal durchgemessen. http://www.icpdf.com/icpdf_datasheet_9_datasheet/BA5938FM_pdf_1516511/BA5938FM_2.html#view

Leider nur auf Japanisch. 10, 21 , 22 auf Masse haben keinen Kurzschluss. Tracking und Focus , habe ich keine Ahnung welches von denen das sein soll.


http://pdf.datasheetcatalog.com/datasheet/rohm/ba6665fm.pdf
Pin 25 und 27 auf Masse ist hier auch OK.

Werde nochmal den Restzinn der ESD Punkte ganz entlöten um das als Fehlerquelle auszuschliessen. Schaut halt etwas unsauber aus. Wenn ich messe gibts da eigentlich keinen Durchgang zwischen den Leitungen. Weiss nicht was sonst noch zu tun ist.

Werde dann nochmal die Navi DVDs mit KProbe scannen und gucken wie gut lesbar die sind.

Das Problem an diesem Laufwerk ist, dass man es halt nicht wirklich testen kann. Bei der PS2 konnte man ja gucken ob er CDs abspielt, VCDs, DVDs originale usw usw. Dieses Laufwerk gibt dem Auto nur bescheid ob eine Navi DVD drin ist oder nicht. Sonst nichts. Also trial und error.


Link youtube video : https://www.youtube.com/watch?v=q91cEzWe0Fw



« Letzte Änderung: 12. Dezember 2016, 21:12:34 von RockNRolla »

Takeshi

  • Administrator
  • Lv 99: Freak
  • *****
  • Online Online
  • Beiträge: 29251
  • Geschlecht: Männlich
    • Profil anzeigen
    • trisaster.de
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #1 am: 12. Dezember 2016, 20:56:26 »
Ach, Modcontrol gibt es nicht mehr? Ist ja ein Ding. Na so was bekomme ich gar nicht mit, da ich schon länger nur noch hier aktiv bin, für mehr hab ich keine Zeit. Und wer was von mir will, muss halt hier fragen ::) ;)
Wenn ich jetzt nich völlig was übersehen hab, gibt es dann im deutschsprachigen Raum nur noch psxtools. Die Konsolen-Foren sterben echt aus ...

Naja. Man ist auch inzwischen Erwachsen geworden und statt PS2s hantiert man nun mit Navigationslaufwerken, weil man inzwischen einen Führerschein und ein Auto hat :D

Das hat ja nicht mal viel mit erwachsen zu tun, die Technik wird auch immer neuer und man befasst sich immer mit der aktuell verbreiteten Technik. Gut, wenn man ganz erwachsen ist, dann befasst man sich mit den Konsolen von vor 20 Jahren ;D
Aber ja, dass man erwachsen geworden ist kommt natürlich zwangsläufig hinzu.

Nun aber zu deinem eigentlichen Problem.

Fotos wären auf jeden Fall gut, denn dann bekommt man erst mal einen Überblick über den prinzipiellen Aufbau, was da alles drauf sitzt.

Was du testen kannst: Leuchtet der Laser rot? Wird er beim Starten zur Mitte gefahren?
Hast du irgendwie Zugriff auf ein funktionierendes Laufwerk?

RockNRolla

  • Lv 4: Great Member
  • ***
  • Offline Offline
  • Beiträge: 201
    • Profil anzeigen
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #2 am: 12. Dezember 2016, 21:34:41 »

Fotos wären auf jeden Fall gut, denn dann bekommt man erst mal einen Überblick über den prinzipiellen Aufbau, was da alles drauf sitzt.

Was du testen kannst: Leuchtet der Laser rot? Wird er beim Starten zur Mitte gefahren?
Hast du irgendwie Zugriff auf ein funktionierendes Laufwerk?

Fotos sind hier http://imgur.com/a/8eNDh

Ursprünglicher Post wurde auch schon editiert mit Messungen.
Laser wird rot wenn ich selber 2 oder 3 AAA Batterien zusammenschalte als Stromquelle und am Flex überbrücke. Glaube aber nur bei CD. CD Poti liegt bei 200 Ohm. War auch beim alten so niedrig.

Der alte leuchtet allerdings heller wenn ich das selbe mache. keine Ahnung warum. Vielleicht ist es auch der DVD Laser. Weil beim alten hab ich den Poti richtig runter gedreht. Würde so Sinn machen.


Takeshi

  • Administrator
  • Lv 99: Freak
  • *****
  • Online Online
  • Beiträge: 29251
  • Geschlecht: Männlich
    • Profil anzeigen
    • trisaster.de
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #3 am: 12. Dezember 2016, 23:14:10 »
Oh Mist, das habe ich ganz vergessen zu erwähnen, ich hatte es noch im Kopf. Der absolute Wert der Potis ist total egal! Es gibt kein festes Verhältnis zwischen Wert des Potis und der Leistung des Lasers. Das Poti ist nur eine Art Signalgeber für die Elektronik, damit die weiß, was die mit dem Laser machen soll. Je nach System sind mal 100 Ω normal, bei anderen sind es 20 kΩ. Wenn du für ein System die üblichen Werte kennst, dann kannst du dich daran orientieren. Aber ist es ein anderes System, sagt dir der Wert absolut gar nichts. In der Wii ist es zum Beispiel sogar so, dass zu dem Poti noch ein fester Widerstand in Reihe geschaltet ist. Dadurch ist der Wert insgesamt höher als der, den du am Poti direkt misst und du kannst einen bestimmten Wert gar nicht überschreiten.
Aus diesem Grund war es auch gar nicht klug das Poti auf einen dir sympatischen Wert runterzudrehen, weil das für das System sicher ein unüblicher Wert war.

Die Fotos sind schon mal gut.
Auf der Innenseite der BA5938FM steuert vermutlich den Laser an, sprich Focus/Tracking und ich denke auch den Schlittenmotor. Das andere IC auf der Seite wird der Controller für die Laserzelle sein, der die analogen Daten auswertet und digital weiterleitet.
Auf der Außenseite sitzt, wenn die Fachbandkabel unten sind, in der Mitte der dicke DSP für das Laufwerk, rechts RAM, links der Speicher mit der Firmware. Hinten links der BA6665FM macht wahrscheinlich den Disc-Motor. In der PS2 sitzt übrigens der BA6664FM. So weit erst mal der Aufbau der Platine.

CD siehst du meine ich wesentlich besser als DVD, bin mir aber blöderweise gerade doch etwas unsicher. Grund: CD ist langwelliger (weil älter) und liegt noch weiter entfernt vom sichtbaren Bereich, DVD ist da schon näher drin, das Auge ist da empfindlicher. Es kann sein, dass bei einem Laser ein Kurzschluss zwischen CD und DVD vorliegt und dann DVD leuchtet, wenn du an CD gehst.
Ich hatte aber auch gar nicht dran gedacht einen Strom auf die Laserdioden zu geben. Mir ging es eher darum, ob im regulären Betrieb die Laser leuchten - explizit bei beiden Lasern! Sprich auch wichtig: gibt es da einen Unterschied? Und bewegt sich die Linse bei einem der Laser?

RockNRolla

  • Lv 4: Great Member
  • ***
  • Offline Offline
  • Beiträge: 201
    • Profil anzeigen
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #4 am: 12. Dezember 2016, 23:34:23 »
Das hast du richtig analysiert. Die Chips sind jeweils äquivalente bzw neuere Versionen als die in der PS2.
Recht ähnlich das meiste.

Die Lasereinheit kann ich wie gesagt nicht sehen. Auch wenn ich Sicht hätte wäre es schwierig, da die Einheit an einem Lichtwellenleiter System mit sehr kurzem Kabel hängt. Fast die Hälfte des Laufwerks verschwindet hinter der Kofferraumverkleidung, ohne dass man dieses ganz reinschiebt. Sehr eng und sehr wenig platz zum arbeiten.

Bis jetzt war meine Diagnose rein akustischer Natur. Ich höre das andrehen der Disc. Das kann ich auch etwas sehen. Dann höre ich bei DVD vorallem wie der Laser versucht zu justieren. Ich glaub der Laserkopf springt sehr schnell hintereinander. und versucht glaube ich zu fokussieren So hört es sich zumindest für mich an.
Die Lasereinheit ist auch nach einem Versuch immer an einer anderen Stelle als ich sie eingebaut habe. Dh der schlitten funktioniert.

Dann spint er runter und versucht es dann nochmal. Unendlich oft.
Bei CD ist es ein klein wenig anders. Hier dreht er etwas länger und es gibt einem einen gesünderen Eindruck, als würde er endlich anfangen zu lesen. Bricht dann aber auch irgendwann ab. Kann natürlich sein, dass er verweigert weil er ne CD statt DVD erkannt hat.

Ich versuche morgen noch mal einen Testlauft. Ein neuer Laser ist bereits bestellt. Mögliche Fehlerquelle könnte auch eventuell sein dass ich irgendwo in die flex reingeschnitten habe. Habe das aber auch oft nachgeguckt und sieht eigentlich ok aus. (Musste wie im Video das überschüssige Material ausserhalb der Leitungen wegschneiden damit das Kabel durch den Schlitz passt und sich frei bewegen kann wenn die Lasereinheit sich bewegt)



Takeshi

  • Administrator
  • Lv 99: Freak
  • *****
  • Online Online
  • Beiträge: 29251
  • Geschlecht: Männlich
    • Profil anzeigen
    • trisaster.de
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #5 am: 13. Dezember 2016, 00:07:35 »
Ich höre das andrehen der Disc.

Das ist eine sehr wichtige Information! Wenn die andreht, kann der Laser auch irgendetwas sehen. Der Motor zum Drehen der Disc und auch der Schlittenmotor scheinen zu arbeiten, die ganze Initialisierungskette wird abgearbeitet.

Eine mögliche erklärung für das Verhalten bei CD und DVD: Die DVD wird als CD gelesen, das ist so weit normal. Der Laser sieht eine Disc, kann sie aber nicht lesen, schließt daraus, dass es eine DVD sein muss, schaltet also auf DVD um und DVD geht gar nicht mehr, ergo bricht er ab.

Wenn es der Laser nicht ist, würde ich den Treiber einmal tauschen. Um die Wartezeit zu verkürzen, würde ich an deiner Stelle jetzt schon mal einen BA5938FM aus China bestellen, die kosten um 1 bis 2 €. Am besten gleich 2 kaufen bei dem Preis. Ich sehe auch gerade, die sind nicht von unten verlötet. Wenn es auf das Geld nicht ganz so sehr ankommt, noch einen BA6665FM dazu, kostet genau so viel. Glaube aber nicht, dass der das ist.

RockNRolla

  • Lv 4: Great Member
  • ***
  • Offline Offline
  • Beiträge: 201
    • Profil anzeigen
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #6 am: 14. Dezember 2016, 12:57:47 »
Gestern nochmal probiert. Laser hat sich sehr passiv verhalten. Nur kurzes andrehen der Disc und dann pause.

Heute mache ich das Laufwerk auf und siehe da, die flex ist beim fahren auf dem Schlitten gerissen  ::)

Was heisst eigentlich von unten verlötet? Und weisst du was es mit der braunen Pampe auf sich hat? War sehr nervig. Musste die Kontakte freikratzen um auf Durchgang zu prüfen.

Takeshi

  • Administrator
  • Lv 99: Freak
  • *****
  • Online Online
  • Beiträge: 29251
  • Geschlecht: Männlich
    • Profil anzeigen
    • trisaster.de
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #7 am: 14. Dezember 2016, 16:03:36 »
Was heisst eigentlich von unten verlötet?

Na ja, eine Lötfläche von unten halt, unter dem Chip, da kommst du mit dem Lötkolben nicht dran. Aber das hat der ja eh nicht.

Und weisst du was es mit der braunen Pampe auf sich hat? War sehr nervig. Musste die Kontakte freikratzen um auf Durchgang zu prüfen.

Ich weiß nicht sicher, was das ist. Gibt viel braunes Zeug. Das kann Flussmittel sein (scheint aber nicht so), kann Schutzlack sein, das kann da sein um Leute bei der Reparatur zu nerven, ...

RockNRolla

  • Lv 4: Great Member
  • ***
  • Offline Offline
  • Beiträge: 201
    • Profil anzeigen
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #8 am: 14. Dezember 2016, 16:30:57 »
Was heisst eigentlich von unten verlötet?

Na ja, eine Lötfläche von unten halt, unter dem Chip, da kommst du mit dem Lötkolben nicht dran. Aber das hat der ja eh nicht.

Und weisst du was es mit der braunen Pampe auf sich hat? War sehr nervig. Musste die Kontakte freikratzen um auf Durchgang zu prüfen.




Ich weiß nicht sicher, was das ist. Gibt viel braunes Zeug. Das kann Flussmittel sein (scheint aber nicht so), kann Schutzlack sein, das kann da sein um Leute bei der Reparatur zu nerven, ...

Ach du meinst sowas wie BGA? Ok.

Jetzt heisst es erst mal auf den neuen Laser warten. In der Zwischenzeit hab ich den alten Laser versucht zu entblößen um zu gucken ob man die Flex klauen kann.

Scheint relativ schwierig zu sein der Vorgang.

http://imgur.com/a/xcmlT

Takeshi

  • Administrator
  • Lv 99: Freak
  • *****
  • Online Online
  • Beiträge: 29251
  • Geschlecht: Männlich
    • Profil anzeigen
    • trisaster.de
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #9 am: 14. Dezember 2016, 17:24:59 »
Nein, meine ich nicht. Es geht zwar etwas in die Richtung, hat aber mit BGAs trotzdem noch viel zu tun.

Die Laserzelle ist eventuell verschweißt und nicht gelötet, dann wird es schwer das Flachbandkabel umzulöten.

RockNRolla

  • Lv 4: Great Member
  • ***
  • Offline Offline
  • Beiträge: 201
    • Profil anzeigen
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #10 am: 14. Dezember 2016, 17:57:08 »
Hier noch ein paar Bildchen. Man sieht auch das Problem beim gebogenen flex. Muss beim Anschliessen auf der Rückseite am connector gefaltet und geklebt werden. Wenn man sehr oft ein und ausbaut zum testen , wie ich, passiert es irgendwann mal dass man ausversehen zu stramm festklebt und an einer gewissen stelle dann die flex zu kurz ist wenn sie woanders hinfährt. Zudem glaube ich dass es an einer stelle gerissen ist wo eine kerbe war. sprich wo ich von zwei seiten schneiden musste weil die Rasierklinge zu schwach war und eben kein glatter schnitt.

Komisch erklärt. Versuchs nochmal einfacher. Man kennt doch zb Chipstüten und ähnliche Verpackungen. Die haben immer eine schwache Stelle zum aufreissen bzw öffnen der Packung. So gings diesem ribbon cable.

http://imgur.com/a/DzJh0

Takeshi

  • Administrator
  • Lv 99: Freak
  • *****
  • Online Online
  • Beiträge: 29251
  • Geschlecht: Männlich
    • Profil anzeigen
    • trisaster.de
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #11 am: 14. Dezember 2016, 23:01:01 »
Ist ja ganz einfach eigentlich. Versuche eine Metall- oder Plastikfolie an einer geraden Seite einzureißen, das ist schwer. Aber sobald du nur einen Riss fortführen musst, geht es fast von selbst.

Ich kann dir da als Tipp geben, klebe einen Streifen Klebeband auf das Flachbandkabel, das verstärkt es. Wenn du das halb auf den Rand klebst und umschlägst, ist es am besten. Das macht es natürlich aber auch steifer. Du solltest vermeiden den Klebestreifen an einer Knickstelle enden zu lassen, denn dann verbiegt es sich nicht mehr gleichmäßig über die Länge, sondern nur an dem Ende des Klebestreifens und dann bricht es noch schneller.

RockNRolla

  • Lv 4: Great Member
  • ***
  • Offline Offline
  • Beiträge: 201
    • Profil anzeigen
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #12 am: 15. Dezember 2016, 00:09:15 »
Genau so ist es.

Hab jetzt mal die Flex ausgebaut. Schon ziemlich komplex. Da hängen an verschiedenen Enden noch viele Elemente dran, wie Linse mit Coils und Potis usw . Mal sehen ob ich da weitermache.

Takeshi

  • Administrator
  • Lv 99: Freak
  • *****
  • Online Online
  • Beiträge: 29251
  • Geschlecht: Männlich
    • Profil anzeigen
    • trisaster.de
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #13 am: 15. Dezember 2016, 00:27:34 »
Ja, das ist ja klar, ist ja immer viel drin in so einer Lasereinheit. Du brauchst immer mindestens die Laserdiode + Empfangszelle (manchmal in einem) und die Spulen an der Linse. Das rauszufummeln kann schon aufwendig sein. Da würde ich fast lieber gleich einen passenden Laser für 20 bis 30 € kaufen, statt einen günstigen und daran herumfummeln. Am Ende kaufst du davon 3 und es funktioniert nicht mal.

RockNRolla

  • Lv 4: Great Member
  • ***
  • Offline Offline
  • Beiträge: 201
    • Profil anzeigen
Re: Mercedes NTG1 Navi Laufwerk
« Antwort #14 am: 15. Dezember 2016, 12:24:50 »
Jo. Werde ich wohl machen wenn der Ersatzlaser auch nicht funktioniert. (Habe dafür ja nichts gezahlt)

Vom Flexkabel ersetzen halte ich ja nicht viel. bzw sehe da jetzt keinen Erfolg dass ich das schaffe und habe daher auch wenig lust drauf obwohls als Zeitüberbrückung gelten sollte.

Welche Teile kann ich eigentlich übernehmen und welche sind verschlissen? Die Laserdiode (gold mit drei Pins) habe ich schon abggemacht. Die Linse mit den Spulen sieht sehr filigran aus.

Falls eigentlich nur die Laserdiode verschlissen ist, hätte ich auch an der Seite der alten Einheit nur den Laser abmachen können und den neuen rein.


PS: Der günstigste den ich finden kann kostet 80 Dollar. Muss mal weitergucken. Falls ich nicht fündig werde muss ichs mit nem Reperaturservice oder sonst was versuchen.

Hätte mich seinerzeit mit diesen hier zudecken sollen http://www.pollin.de/shop/dt/NzQ3OTYzOTk-/Unterhaltungselektronik/Audio/Ersatzteile/Lasereinheit_SF_HD4.html
« Letzte Änderung: 15. Dezember 2016, 12:39:52 von RockNRolla »